using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]+)\/((?:\d{1,3}\.){3,4}\d{1,3})$";
string input = @"Host/12.43.211.212.1
DNS/8.8.8.8
Version/1.27.0.0.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}