use strict;
my $str = 'Host/12.43.211.212.1
DNS/8.8.8.8
Version/1.27.0.0.1';
my $regex = qr/^([a-zA-Z]+)\/((?:\d{1,3}\.){3,4}\d{1,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}