package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]+)\/((?:\d{1,3}\.){3,4}\d{1,3})$`)
var str = `Host/12.43.211.212.1
DNS/8.8.8.8
Version/1.27.0.0.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}