// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]+)\/((?:\d{1,3}\.){3,4}\d{1,3})$").unwrap();
let string = "Host/12.43.211.212.1
DNS/8.8.8.8
Version/1.27.0.0.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}