re = /^([a-zA-Z]+)\/((?:\d{1,3}\.){3,4}\d{1,3})$/m
str = 'Host/12.43.211.212.1
DNS/8.8.8.8
Version/1.27.0.0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end