# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h2>(\d+)<\\/h2>\r?\n\s*Passed/<<<$1>>>/g;t' <<< "<div class=\"col-sm-2 col-sm-offset-1\">
<div class=\"countBox success\" id=\"success\">
<h2>467</h2>
Passed Tests
<span class=\"glyphicon glyphicon-eye-open\"></span>
</div>
</div>"