import Foundation
let pattern = #"<h2>(\d+)<\/h2>\r?\n\s*Passed"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="col-sm-2 col-sm-offset-1">
<div class="countBox success" id="success">
<h2>467</h2>
Passed Tests
<span class="glyphicon glyphicon-eye-open"></span>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<<<$1>>>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)