import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2>(\\d+)<\\/h2>\\r?\\n\\s*Passed";
final String string = "<div class=\"col-sm-2 col-sm-offset-1\">\n"
+ "<div class=\"countBox success\" id=\"success\">\n"
+ "<h2>467</h2>\n"
+ " Passed Tests\n"
+ " <span class=\"glyphicon glyphicon-eye-open\"></span>\n"
+ " </div>\n"
+ " </div>";
final String subst = "<<<$1>>>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}