use strict;
my $str = 'Reese
Reese
Reese';
my $regex = qr/(?<=^.{3})\w/mp;
my $subst = 't';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";