#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)tagged.[^\W\s]+"
Local $sString = "tagged.big)" & @CRLF & _
"tagged.big " & @CRLF & _
"tagged.big " & @CRLF & _
"tagged.medium)" & @CRLF & _
"tagged.big1" & @CRLF & _
"tagged.big2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")