$re = '/tagged.[^\W\s]+/m';
$str = 'tagged.big)
tagged.big
tagged.big
tagged.medium)
tagged.big1
tagged.big2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);