re = /tagged.[^\W\s]+/m
str = 'tagged.big)
tagged.big
tagged.big
tagged.medium)
tagged.big1
tagged.big2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end