package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)tagged.[^\W\s]+`)
var str = `tagged.big)
tagged.big
tagged.big
tagged.medium)
tagged.big1
tagged.big2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}