using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tagged.[^\W\s]+";
string input = @"tagged.big)
tagged.big
tagged.big
tagged.medium)
tagged.big1
tagged.big2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}