using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[BR]?|(?<!L)C)REF|^(?!\|)";
string substitution = @"|\g<0>";
string input = @"XYZ:MUMBAI UNIVERSITYCREF:PUNE UNIVERSITYBREF:DADAR UNIVERSITYRREF:KOLHAPUR UNIVERCITY LLCREF:SOLAPUR UNIVERSITY
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}