$re = '/(?:[BR]?|(?<!L)C)REF|^(?!\|)/';
$str = 'XYZ:MUMBAI UNIVERSITYCREF:PUNE UNIVERSITYBREF:DADAR UNIVERSITYRREF:KOLHAPUR UNIVERCITY LLCREF:SOLAPUR UNIVERSITY
';
$subst = "|\g<0>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;