use strict;
my $str = 'XYZ:MUMBAI UNIVERSITYCREF:PUNE UNIVERSITYBREF:DADAR UNIVERSITYRREF:KOLHAPUR UNIVERCITY LLCREF:SOLAPUR UNIVERSITY
';
my $regex = qr/(?:[BR]?|(?<!L)C)REF|^(?!\|)/p;
my $subst = '|\\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";