const regex = new RegExp('(?:[BR]?|(?<!L)C)REF|^(?!\\|)', 'g')
const str = `XYZ:MUMBAI UNIVERSITYCREF:PUNE UNIVERSITYBREF:DADAR UNIVERSITYRREF:KOLHAPUR UNIVERCITY LLCREF:SOLAPUR UNIVERSITY
`;
const subst = `|\g<0>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);