using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('|""|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)('|""|)(\s)?(:|=)(\s)?('|"")(.*)('|"")";
string input = @"'password':'asdf'
'password' :'asdf'
'password': 'asdf'
'password' : 'asdf'
'password'='asdf'
'password' ='asdf'
'password'= 'asdf'
'password' = 'asdf'
""password"":""asdf""
""password"" :""asdf""
""password"": ""asdf""
""password"" : ""asdf""
""password""=""asdf""
""password"" =""asdf""
""password""= ""asdf""
""password"" = ""asdf""
password=""asdf""
password =""asdf""
password= ""asdf""
password = ""asdf""
password='asdf'
password ='asdf'
password= 'asdf'
password = 'asdf'
password=asdf
password =asdf
password= asdf
password = asdf
Password=asdf
secret = ""asdf""
Secret='asdf'
asdfpassword=asdf
emailPassword = soreeeaukr,so;d[""asdfasdf""];
asdfasdfpasswordasdfasdf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}