// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"('|"|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)('|"|)(\s)?(:|=)(\s)?('|")(.*)('|")"#).unwrap();
let string = "'password':'asdf'
'password' :'asdf'
'password': 'asdf'
'password' : 'asdf'
'password'='asdf'
'password' ='asdf'
'password'= 'asdf'
'password' = 'asdf'
\"password\":\"asdf\"
\"password\" :\"asdf\"
\"password\": \"asdf\"
\"password\" : \"asdf\"
\"password\"=\"asdf\"
\"password\" =\"asdf\"
\"password\"= \"asdf\"
\"password\" = \"asdf\"
password=\"asdf\"
password =\"asdf\"
password= \"asdf\"
password = \"asdf\"
password='asdf'
password ='asdf'
password= 'asdf'
password = 'asdf'
password=asdf
password =asdf
password= asdf
password = asdf
Password=asdf
secret = \"asdf\"
Secret='asdf'
asdfpassword=asdf
emailPassword = soreeeaukr,so;d[\"asdfasdf\"];
asdfasdfpasswordasdfasdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}