import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('|\"|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)('|\"|)(\\s)?(:|=)(\\s)?('|\")(.*)('|\")";
final String string = "'password':'asdf'\n"
+ "'password' :'asdf'\n"
+ "'password': 'asdf'\n"
+ "'password' : 'asdf'\n\n"
+ "'password'='asdf'\n"
+ "'password' ='asdf'\n"
+ "'password'= 'asdf'\n"
+ "'password' = 'asdf'\n\n"
+ "\"password\":\"asdf\"\n"
+ "\"password\" :\"asdf\"\n"
+ "\"password\": \"asdf\"\n"
+ "\"password\" : \"asdf\"\n\n"
+ "\"password\"=\"asdf\"\n"
+ "\"password\" =\"asdf\"\n"
+ "\"password\"= \"asdf\"\n"
+ "\"password\" = \"asdf\"\n\n"
+ "password=\"asdf\"\n"
+ "password =\"asdf\"\n"
+ "password= \"asdf\"\n"
+ "password = \"asdf\"\n\n"
+ "password='asdf'\n"
+ "password ='asdf'\n"
+ "password= 'asdf'\n"
+ "password = 'asdf'\n\n"
+ "password=asdf\n"
+ "password =asdf\n"
+ "password= asdf\n"
+ "password = asdf\n\n"
+ "Password=asdf\n\n"
+ "secret = \"asdf\"\n"
+ "Secret='asdf'\n\n"
+ "asdfpassword=asdf\n"
+ "emailPassword = soreeeaukr,so;d[\"asdfasdf\"];\n"
+ "asdfasdfpasswordasdfasdf\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}