$re = '/(\'|"|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)(\'|"|)(\s)?(:|=)(\s)?(\'|")(.*)(\'|")/';
$str = '\'password\':\'asdf\'
\'password\' :\'asdf\'
\'password\': \'asdf\'
\'password\' : \'asdf\'
\'password\'=\'asdf\'
\'password\' =\'asdf\'
\'password\'= \'asdf\'
\'password\' = \'asdf\'
"password":"asdf"
"password" :"asdf"
"password": "asdf"
"password" : "asdf"
"password"="asdf"
"password" ="asdf"
"password"= "asdf"
"password" = "asdf"
password="asdf"
password ="asdf"
password= "asdf"
password = "asdf"
password=\'asdf\'
password =\'asdf\'
password= \'asdf\'
password = \'asdf\'
password=asdf
password =asdf
password= asdf
password = asdf
Password=asdf
secret = "asdf"
Secret=\'asdf\'
asdfpassword=asdf
emailPassword = soreeeaukr,so;d["asdfasdf"];
asdfasdfpasswordasdfasdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);