const regex = /('|"|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)('|"|)(\s)?(:|=)(\s)?('|")(.*)('|")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'|"|)([Pp]assword|[Ss]ecret|[Aa]piKey|[Pp]rivateKey)(\'|"|)(\\s)?(:|=)(\\s)?(\'|")(.*)(\'|")', 'g')
const str = `'password':'asdf'
'password' :'asdf'
'password': 'asdf'
'password' : 'asdf'
'password'='asdf'
'password' ='asdf'
'password'= 'asdf'
'password' = 'asdf'
"password":"asdf"
"password" :"asdf"
"password": "asdf"
"password" : "asdf"
"password"="asdf"
"password" ="asdf"
"password"= "asdf"
"password" = "asdf"
password="asdf"
password ="asdf"
password= "asdf"
password = "asdf"
password='asdf'
password ='asdf'
password= 'asdf'
password = 'asdf'
password=asdf
password =asdf
password= asdf
password = asdf
Password=asdf
secret = "asdf"
Secret='asdf'
asdfpassword=asdf
emailPassword = soreeeaukr,so;d["asdfasdf"];
asdfasdfpasswordasdfasdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}