#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[*\$\@\#\$\-\&\%\#\+\=\/])[0-9]{1,}(?=)|[0-9]{1,}(?=[*\$\@\#\$%\-\=\/\&\+])"
Local $sString = "......262....300...................507.....961..............668.....................189.906...........................624.................." & @CRLF & _
"..148.................805..130..880*...........*684.............*......*..............*..-......%.................$........17...65....91*..." & @CRLF & _
"......272.....464.....=......*.........................208*.....260.967.38.......692*.........676............@247..652.585.#......@......74." & @CRLF & _
".................*734........772......171.........728$.....52........................747.=866............350...........*...................."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")