$re = '/(?<=[*\$\@\#\$\-\&\%\#\+\=\/])[0-9]{1,}(?=)|[0-9]{1,}(?=[*\$\@\#\$%\-\=\/\&\+])/m';
$str = '......262....300...................507.....961..............668.....................189.906...........................624..................
..148.................805..130..880*...........*684.............*......*..............*..-......%.................$........17...65....91*...
......272.....464.....=......*.........................208*.....260.967.38.......692*.........676............@247..652.585.#......@......74.
.................*734........772......171.........728$.....52........................747.=866............350...........*....................';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);