import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[*\\$\\@\\#\\$\\-\\&\\%\\#\\+\\=\\/])[0-9]{1,}(?=)|[0-9]{1,}(?=[*\\$\\@\\#\\$%\\-\\=\\/\\&\\+])";
final String string = "......262....300...................507.....961..............668.....................189.906...........................624..................\n"
+ "..148.................805..130..880*...........*684.............*......*..............*..-......%.................$........17...65....91*...\n"
+ "......272.....464.....=......*.........................208*.....260.967.38.......692*.........676............@247..652.585.#......@......74.\n"
+ ".................*734........772......171.........728$.....52........................747.=866............350...........*....................";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}