using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[*\$\@\#\$\-\&\%\#\+\=\/])[0-9]{1,}(?=)|[0-9]{1,}(?=[*\$\@\#\$%\-\=\/\&\+])";
string input = @"......262....300...................507.....961..............668.....................189.906...........................624..................
..148.................805..130..880*...........*684.............*......*..............*..-......%.................$........17...65....91*...
......272.....464.....=......*.........................208*.....260.967.38.......692*.........676............@247..652.585.#......@......74.
.................*734........772......171.........728$.....52........................747.=866............350...........*....................";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}