import Foundation
let pattern = ##"(?<=[*\$\@\#\$\-\&\%\#\+\=\/])[0-9]{1,}(?=)|[0-9]{1,}(?=[*\$\@\#\$%\-\=\/\&\+])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
......262....300...................507.....961..............668.....................189.906...........................624..................
..148.................805..130..880*...........*684.............*......*..............*..-......%.................$........17...65....91*...
......272.....464.....=......*.........................208*.....260.967.38.......692*.........676............@247..652.585.#......@......74.
.................*734........772......171.........728$.....52........................747.=866............350...........*....................
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)