import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^";
final String string = "shoot_0001.jpg\n"
+ "shoot_0002.jpg\n"
+ "shoot_0003.jpg\n"
+ "shoot_0004.jpg\n"
+ "shoot_0005.jpg\n"
+ "shoot_0006.jpg\n"
+ "shoot_0007.jpg\n"
+ "shoot_0008.jpg\n"
+ "shoot_0009.jpg\n"
+ "shoot_0010.jpg";
final String subst = "title_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}