re = /^/m
str = 'shoot_0001.jpg
shoot_0002.jpg
shoot_0003.jpg
shoot_0004.jpg
shoot_0005.jpg
shoot_0006.jpg
shoot_0007.jpg
shoot_0008.jpg
shoot_0009.jpg
shoot_0010.jpg'
subst = 'title_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result