# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^"
test_str = ("shoot_0001.jpg\n"
"shoot_0002.jpg\n"
"shoot_0003.jpg\n"
"shoot_0004.jpg\n"
"shoot_0005.jpg\n"
"shoot_0006.jpg\n"
"shoot_0007.jpg\n"
"shoot_0008.jpg\n"
"shoot_0009.jpg\n"
"shoot_0010.jpg")
subst = "title_"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.