#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z]|\s|^)((\+84|0)(1[2689]|9)+[0-9]{8})([a-zA-Z]|\s|$)"
Local $sString = "0989914009 nguyeng quangthang0989914009 thang 9301234567898 123 01201234567892 0989914009 nguyeng quang nn thang +84989914009" & @CRLF & _
"nmv nguyeng quang thang0989914009"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")