package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z]|\s|^)((\+84|0)(1[2689]|9)+[0-9]{8})([a-zA-Z]|\s|$)`)
var str = `0989914009 nguyeng quangthang0989914009 thang 9301234567898 123 01201234567892 0989914009 nguyeng quang nn thang +84989914009
nmv nguyeng quang thang0989914009`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}