using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(3[01]|[12][0-9]|0?[1-9])-11-2018 (2[0-3]|[10]?\d)h([0-5]?[0-9])m";
string input = @"output 2-11-2018 23h56m.xml
output 2-11-2018 23h6m.xml
output 2-11-2018 3h6m.xml
output 22-11-2018 3h6m.xml
output 22-11-2018 12h6m.xml
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}