import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(3[01]|[12][0-9]|0?[1-9])-11-2018 (2[0-3]|[10]?\\d)h([0-5]?[0-9])m";
final String string = "output 2-11-2018 23h56m.xml\n"
+ "output 2-11-2018 23h6m.xml\n"
+ "output 2-11-2018 3h6m.xml\n"
+ "output 22-11-2018 3h6m.xml\n"
+ "output 22-11-2018 12h6m.xml\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}