re = /\b(3[01]|[12][0-9]|0?[1-9])-11-2018 (2[0-3]|[10]?\d)h([0-5]?[0-9])m/m
str = 'output 2-11-2018 23h56m.xml
output 2-11-2018 23h6m.xml
output 2-11-2018 3h6m.xml
output 22-11-2018 3h6m.xml
output 22-11-2018 12h6m.xml
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end