const regex = new RegExp('\\b(3[01]|[12][0-9]|0?[1-9])-11-2018 (2[0-3]|[10]?\\d)h([0-5]?[0-9])m', 'gm')
const str = `output 2-11-2018 23h56m.xml
output 2-11-2018 23h6m.xml
output 2-11-2018 3h6m.xml
output 22-11-2018 3h6m.xml
output 22-11-2018 12h6m.xml
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}