// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(3[01]|[12][0-9]|0?[1-9])-11-2018 (2[0-3]|[10]?\d)h([0-5]?[0-9])m").unwrap();
let string = "output 2-11-2018 23h56m.xml
output 2-11-2018 23h6m.xml
output 2-11-2018 3h6m.xml
output 22-11-2018 3h6m.xml
output 22-11-2018 12h6m.xml
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}