using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*blocks[[:space:]]+super.*\[(_U|U_|__)\][[:space:]]|md[[:digit:]]+[[:space:]]+:[[:space:]]+active[[:space:]]+[[:punct:][:alnum:]]+[[:space:]]+raid[[:digit:]]+[[:space:]]+|md[[:digit:]]+[[:space:]]+:[[:space:]]+[^[active]][[:space:]]+)";
string input = @"Personalities : [raid1]
md1 : active (test) raid1 xvde1[2] xvdf1[1]
104791040 blocks super 1.2 [2/2] [U_]
md0 : notok raid1 xvda1[0] xvdb1[1]
26195968 blocks super 1.2 [2/2] [_U]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}