import re
regex = re.compile(r"(.*blocks[[:space:]]+super.*\[(_U|U_|__)\][[:space:]]|md[[:digit:]]+[[:space:]]+:[[:space:]]+active[[:space:]]+[[:punct:][:alnum:]]+[[:space:]]+raid[[:digit:]]+[[:space:]]+|md[[:digit:]]+[[:space:]]+:[[:space:]]+[^[active]][[:space:]]+)")
test_str = ("Personalities : [raid1]\n"
"md1 : active (test) raid1 xvde1[2] xvdf1[1]\n"
" 104791040 blocks super 1.2 [2/2] [U_]\n\n"
"md0 : notok raid1 xvda1[0] xvdb1[1]\n"
" 26195968 blocks super 1.2 [2/2] [_U]\n\n\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")