// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*blocks[[:space:]]+super.*\[(_U|U_|__)\][[:space:]]|md[[:digit:]]+[[:space:]]+:[[:space:]]+active[[:space:]]+[[:punct:][:alnum:]]+[[:space:]]+raid[[:digit:]]+[[:space:]]+|md[[:digit:]]+[[:space:]]+:[[:space:]]+[^[active]][[:space:]]+)").unwrap();
let string = "Personalities : [raid1]
md1 : active (test) raid1 xvde1[2] xvdf1[1]
104791040 blocks super 1.2 [2/2] [U_]
md0 : notok raid1 xvda1[0] xvdb1[1]
26195968 blocks super 1.2 [2/2] [_U]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}