$re = '/(.*blocks[[:space:]]+super.*\[(_U|U_|__)\][[:space:]]|md[[:digit:]]+[[:space:]]+:[[:space:]]+active[[:space:]]+[[:punct:][:alnum:]]+[[:space:]]+raid[[:digit:]]+[[:space:]]+|md[[:digit:]]+[[:space:]]+:[[:space:]]+[^[active]][[:space:]]+)/';
$str = 'Personalities : [raid1]
md1 : active (test) raid1 xvde1[2] xvdf1[1]
104791040 blocks super 1.2 [2/2] [U_]
md0 : notok raid1 xvda1[0] xvdb1[1]
26195968 blocks super 1.2 [2/2] [_U]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);