import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*blocks[[:space:]]+super.*\\[(_U|U_|__)\\][[:space:]]|md[[:digit:]]+[[:space:]]+:[[:space:]]+active[[:space:]]+[[:punct:][:alnum:]]+[[:space:]]+raid[[:digit:]]+[[:space:]]+|md[[:digit:]]+[[:space:]]+:[[:space:]]+[^[active]][[:space:]]+)";
final String string = "Personalities : [raid1]\n"
+ "md1 : active (test) raid1 xvde1[2] xvdf1[1]\n"
+ " 104791040 blocks super 1.2 [2/2] [U_]\n\n"
+ "md0 : notok raid1 xvda1[0] xvdb1[1]\n"
+ " 26195968 blocks super 1.2 [2/2] [_U]\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}