#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)img src="".+?png""
Local $sString = "<img src=""https://support.comp.com/inlineimages/1413838988355.png""><br><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br><span style=""font-size: 10.0pt;font-family: Arial , sans-serif;""></span></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">The setup is shown below:</p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">%as2-From%-%srcfilebase%.%srcfileext%<br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><img src=""/inlineimages/1413839088730.png"">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")