import Foundation
let pattern = #"img src="".+?png""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<img src=""https://support.comp.com/inlineimages/1413838988355.png""><br><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br><span style=""font-size: 10.0pt;font-family: Arial , sans-serif;""></span></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">The setup is shown below:</p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">%as2-From%-%srcfilebase%.%srcfileext%<br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><img src=""/inlineimages/1413839088730.png"">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)