re = /img src="".+?png"/m
str = '<img src=""https://support.comp.com/inlineimages/1413838988355.png""><br><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br><span style=""font-size: 10.0pt;font-family: Arial , sans-serif;""></span></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">The setup is shown below:</p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">%as2-From%-%srcfilebase%.%srcfileext%<br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><img src=""/inlineimages/1413839088730.png"">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end