// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)img src="".+?png""#).unwrap();
let string = "<img src=\"\"https://support.comp.com/inlineimages/1413838988355.png\"\"><br><p style=\"\"MARGIN: 0.0in 0.0in 0.0pt;\"\"><br><span style=\"\"font-size: 10.0pt;font-family: Arial , sans-serif;\"\"></span></p><p style=\"\"MARGIN: 0.0in 0.0in 0.0pt;\"\"><br></p><p style=\"\"MARGIN: 0.0in 0.0in 0.0pt;\"\">The setup is shown below:</p><p style=\"\"MARGIN: 0.0in 0.0in 0.0pt;\"\">%as2-From%-%srcfilebase%.%srcfileext%<br></p><p style=\"\"MARGIN: 0.0in 0.0in 0.0pt;\"\"><img src=\"\"/inlineimages/1413839088730.png\"\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}