using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"img src="".+?png""";
string input = @"<img src=""https://support.comp.com/inlineimages/1413838988355.png""><br><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br><span style=""font-size: 10.0pt;font-family: Arial , sans-serif;""></span></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">The setup is shown below:</p><p style=""MARGIN: 0.0in 0.0in 0.0pt;"">%as2-From%-%srcfilebase%.%srcfileext%<br></p><p style=""MARGIN: 0.0in 0.0in 0.0pt;""><img src=""/inlineimages/1413839088730.png"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}