# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=^tags::)|\G(?<!^))(\s*\w+)(?= )/$1,/gm;t' <<< "some random text
tags:: tree dog book razor
some random text
"