$re = '/(?:(?<=^tags::)|\G(?<!^))(\s*\w+)(?= )/m';
$str = 'some random text
tags:: tree dog book razor
some random text
';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;